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CNT5106C Computer Networks 

Experiment 1: Wireless Coverage Map 
Contacts: Teaching Assistant: Sungwook Moon, Instructor: Ahmed Helmy 

 

Introduction 
The goal of this lab is to understand the coverage model and channel characteristics of 

802.11 Wireless LANs. Students are guided to use PocketPC (or their own laptop) 

computers and detection/visualization software to perform various WLANs coverage 

studies. With this lab, students will be able to understand how to detect 802.11 LANs, 

identify access point locations, and find coverage of 802.11 networks.  

 

There are two parts in this experiment. Part I-A is an indoor coverage experiment and 

Part I-B is an outdoor coverage experiment. In Part II, Part II-A is related to Part I-A and 

Part II-B is related to Part I-B.  

 

IMPORTANT NOTICE!! 

You will need to check out a GPS-enabled PDA or Bluetooth GPS at CSE 401 for part I-

B & II-B. However, due to the limited number of available devices, each group will be 

allowed to check out the devices for limited time (penalty applied for late return). A 

Bluetooth dongle will be provided for those without Bluetooth on your any of your laptop 

in your team. Each group needs to contact Sungwook to reserve the time blocks for 

checkout with desired time blocks. Each group may be able to check out a device 

multiple times depending on the schedule and availability. Detailed device checkout 

policy including available time blocks will be available at 

http://www.cise.ufl.edu/~smoon/cnt5106. You need to check the above website as 

frequently as possible for any updates on the experiment. 

 

Note for remote students without groups:  
You have the following two options: 1- Perform only part I-A (indoor measurement). 

You only need one laptop for that experiment. If you cannot obtain a floor plan, you can 

draw a floor plot yourself, or 2- If you cannot perform the actual measurements yourself, 

please contact the TA for existing data files and complete the tasks starting from the ‘post 

processing’ section of each part (i.e., Section iii) and beyond.  

In any case, please inform the TA and the instructor of your choice by email. 

 

Part I-A: Indoor coverage experiment 
 

i- Preparation: 

1. Check the UF wireless coverage map, and choose one building with wireless coverage. 

Obtain the building floor plan through Facilities Planning and construction division at 

Ben hill Griffin stadium, room 232. (or email David Heather dheather@ufl.edu). Come 

up with your routes for a comprehensive sweep of all the corridors on at least three floors 

(all floors if possible). 

 

2. Download Netstumbler (Windows version) at http://www.netstumbler.com/downloads/ 
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Vista users, see APPENDIX. 

 

3. Install and run the program on your laptop computer.  

a) Make sure your wireless LAN is on. 

b) Start Netstumbler application, check if the signal strength for each AP(Access Point) is 

displayed.  

 

ii- Procedure: 

1. Go to the building you choose (please try in a building other than CISE building), run 

Netstumbler to measure signal strength of each AP. 

2. Make up a file name with unique meaning of the location you’re taking the 

measurement, e.g. cse-4f-401-door.   

3. Follow your pre-decided floor sweeping routes, repeat the previous steps, save one set 

of measurement results for every 7~8 foot steps. 

4. Close the window of your measurement in each location after saving it and start a new 

measurement in different locations. 

 

iii- Post-processing: 

1. Open your measurement files by Netstumbler. For every location, log the strongest 

signal strength reading on the floor plan. Color the reading with the following rule: 

x>= -78 : green , -78>x >= -86: yellow, -86>x : red 

** For the buildings having good coverage, you should adjust the signal strength-coloring 

rule accordingly. (e.g. x>= 70: green) Mention any adjustment in the report. 

Hint: your resultant figure should look something like Fig 1 below. 

 

 
Fig 1. Example of indoor coverage map 

 

2. Complete one figure per floor. 

 

Answer the following questions:  
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a) Roughly what percentage of the floors that you surveyed has green coverage? Is this 

percentage the same for all floors surveyed?  

b) Are the green areas at each floor located roughly in the same (or different) parts of the 

building? Where are the red areas usually located? 

 

 

3. Pick one specific AP MAC address. Log all the readings of this specific AP from all of 

your measurement files on the floor plan. Also follow the above color rule. Repeat this 

procedure for at least three APs. 

 

 

Answer the following questions:  

a) From your resultant figure, can you guess the location of the AP? How can you verify 

it? (Hint: usually when you are within 10 feet to the AP, the signal strength should be 

around –50~-60 dbm at your scanner screen) 

b) How far is the AP’s transmission range? How does the AP’s coverage look like? Is it a 

circle or other shape? Is the coverage shape of two different APs the same or different? 

 

Comments: 

Your report should contain at least the following:  

a) Colored signal strength map for each floor in the building 

b) AP specific colored signal strength map for at least three APs 

c) Answer all the questions above 

d) Any additional observations/comments/discussions 

  

Part I-B: Outdoor coverage experiment 
 

i- Preparation 

1. Check the UF wireless coverage map, and choose one outdoor area with wireless 

coverage. (e.g. grass area in front of library west) Plan a comprehensive sweep by zig-zag 

routes as in Fig 2 below.  

** Note that the gap between two parallel paths desired to be around 25~30 feet. 

Horizontal distance and overall size of the route is up to your decision but should be in 

reasonable range.  

Alternatively, you can also plan concentric circle routes to a particular building, with at 

least 3 circles and the distance between circles about 25~30 feet. 
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Gap: 25~30 feetGap: 25~30 feet

 
Fig 2. Example of zig-zag outdoor sweep route 

 

**NOTE: you are also encouraged to go to any area outside UF campus, where a large 

part of outdoor area is covered with WiFi service, e.g. downtown Gainesville.  

 

2. Download Knsgem  at http://www.rjpi.com/knsgem.htm. Make sure knsgem is 

installed in c:\Knsgem folder. 

Download google earth, at earth.google.com 

 

3. Come to CSE401 to check out one GPS-enabled PDA and its usb cable to transfer the 

data to your laptop or Bluetooth GPS for your laptop. You do not need both devices. 

Either one you prefer is enough for your experiment. 

 

* GPS-enabled PDA (HP iPAQ) 

a) Use the iPAQ wireless manager to turn on wifi, and make sure bluetooth is off. 

b) Start WifiFoFum application, check if the main screen starts to show AP signal 

captures. Check tools menu (bottom right-hand side), make sure Autosave is checked. 

c) Go to somewhere by the window where you can see good part of the sky or outside the 

building, check if the GPS connection at bottom right-hand side of WifiFoFum showing 

receiving satellite signal. 

d) From Option, check the scan frequency. If too frequent, the device will not be able to 

work correctly due to heavy load. 5000ms is recommended. 

If everything ok, close the application. (File->Exit) 

IMPORTANT: turn off the device when not in use, otherwise it will drain out the 

battery very quickly. 

 

* Bluetooth GPS 

-- Before using Bluetooth, Windows Vista users need to install NETCommOCX from the 

following website(or any website you can find from): 

http://home.comcast.net/~hardandsoftware/NETCommOCX.htm 

-- Install a program from Bluetooth dongle CD provided at checkout time in the lab 

before using it.  

a) Turn on the Bluetooth GPS by pushing a small circle button. 

b) From Bluetooth setting/manager in your laptop, connect to the Bluetooth GPS (name is 

Nokia LD-3W). Be sure to set with a COM port less than or equal to 16 by a custom 

setting. 
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c) Run Netstumbler and go to View -> Option -> GPS. Match the COM port to what you 

chose at your Bluetooth setting. 

d) Move to where you can receive GPS signal and check if Netstumbler is displaying 

coordinates. 

 

ii- Procedure: 

* GPS-enabled PDA (HP iPAQ) 

1. Go to the outdoor area you choose, turn on PDA, start WifiFoFum application. Wait 

until the new scan results and GPS coordinates (with at least 4 satellite fix) show up 

[this may take 1-5 minutes]. *Click File-> New, to start a new set of measurement.* 

 

2. Follow your pre-decided area sweeping routes with normal walking speed. At the end 

of the route, click File->Save As…to save one set of measurement result. 

 

* Bluetooth GPS 

1. Go to the outdoor area you choose, turn on Bluetooth GPS and your laptop, and start 

Netstumbler application. Wait until the new scan results and GPS coordinates show up 

[this may take 1-5 minutes]. *Click File-> New, to start a new set of measurement.* 

 

2. Follow your pre-decided area sweeping routes with normal walking speed. At the end 

of the route, click File->Save to save one set of measurement result (.ns1). 

 

3. Please skip the following section and go to step 3 in post-processing.  

 

IMPORTANT (only for GPS-enabled PDA):  

a) File Type: choose Wi-scan (*.wis) 

b) Folder: choose the folder specifically created for your course: CNT5106 (if you forgot 

to choose the folder, the files are saved at the root directory by default) 

c) Due to a bug in WifiFoFum, the *.wis you just saved does not contain the correct 

wireless signal information. Instead, there is a work-around: Start “File Explorer” …go to 

root directory (My device), there will be files whose name appear as some negative 7-8 

digit number. e.g.) ‘-89902943.txt’ (name changes from run to run). Identify the file you 

just saved by the date and distinct name from previous files. This is the file you should 

use for post-processing. 

 

iii- Post-processing: 

1. Use the parser provided on the following website 

(http://www.cise.ufl.edu/~smoon/cnt5106/parser.zip) to parse your raw data file. Output 

name can be any names. 

2. Open the parsed file from Netstumbler, click File->save as, choose File Type of 

Netstumbler (*.ns1) 

3. Copy the resultant ns1 file to c:\Knsgem. Clear all previous ns1 file and all temporary 

dbf files every time before running the program, then click knsgem.exe. The resultant 

files will be located in KML folder 

4. Open those kml files in Google earth. 
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Error handling: If your Knsgem program does not work, go over the procedures again 

and see if you omit any of the steps. If still not working, then your language setting may 

be preventing the program from reading a file properly due to certain unidentifiable 

characters. Modify language settings in Windows to English only. 

 

Answer the following questions:  

a) Include the screen plot of your *_ap.kml file on Google earth. Explain what do the 

markers in the main knsgem *_ap.kml files mean? 

 

b) Open your *_sp.kml file on Google earth, uncheck the box in front of the SP item, then 

click the box again so that a √ mark appears. Goto Tools->Options-> (3D View tab) -> 

Primary/Secondary 3d font -> 8 

After these adjustments, include the screen plot of your *_sp.kml file on google earth. 

Explain what do the markers in the *_sp.kml files mean? 

 

c) Uncheck the √ mark in front of the SP item, expand the + sign of SP item, try to 

manually expand each AP and only select the AP that has 20-30 signal level readings. 

Check the box of 20-30 signal level of these APs. 

 

=> Compare this graph with the one from the previous step, roughly what is the 

percentage of measurement points that have 20-30 signal level readings? 

 

d) Uncheck the √ mark in front of the SP item, expand the + sign of SP item, try to find 

an AP with all level (10-20, 20-30, 30-100) of signal strength marks. Hint: For example, 

AP # 29 in the sample sp.kml file posted on class website. 

Click the box in front of the AP you just choose. 

Open your *_c.kml file on Google earth, expand the + sign of C item, find the AP you 

choose above, click the box in front of the AP you just choose. 

 

=> Explain what do the circle in *_c.kml file mean? 

 

e) Uncheck the √ mark in front of the C item, open your *_h.kml file on Google earth, 

expand the + sign of H item, find the AP you choose in the previous step, click the box in 

front of the AP you just choose 

=> explain what do the irregular shape in *_h.kml mean? 

 

f) People tend to think the coverage of an AP is an ideal circle, do you agree? If not, what 

would be your qualitative description of the coverage area based on the plots we get from 

above steps? What do you think are the factors that influence the shape? 

 

Comments: 

 

Your report should at least contain the following:  

a) Answer all the questions above, attach corresponding screen plots 

b) Any additional observations/comments/discussions 
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Part II-A Correlating In-door & Out-door Measurements – first part 
 

i- Preparation: 

From Part I-A, choose one AP that you think its signal should also be available outside 

the building you just surveyed. (Hint: take the scanner to outside, do a brief survey to 

check if any AP you have seen from indoor trace is also available outdoor) 

 

 

 

ii- Procedure:  

Once you decide which part of outside area you want to survey, follow the preparation 

and procedure steps in Part I-B for a comprehensive outdoor coverage sweep. 

 

iii- Post-processing: 

Follow the post-processing steps in Part I-B, but when opening the *.kml files, only 

check those graphs relevant to the particular AP (by MAC address) you choose for this 

assignment. 

 

Answer the following questions:  

a)   Do you see an extended outdoor coverage of the AP you chose from indoor trace? 

b) What is the shape of the extended outdoor coverage? How far is the available 

receiving range for this AP (at outdoor side)? 

 

 

 

Part II-B Correlating In-door & Out-door Measurements – second part 
 

i- Preparation: 

From Part I-B, choose one AP that you think its signal should come from a nearby 

building. (Hint: look at *_sp.xml plots, carefully check each AP and identify the ones that 

has strong signal trend when the measurement points are close to a particular building 

and its signal get weaker as the measurement points get farther from that building.) 

  

ii  & iii – Procedure & Post Processing:  

Go inside that building, follow the procedures and post-processing steps in Part I-A. (you 

might not need a comprehensive floor sweep, just sweep the side of the building close to 

your outdoor survey area) See if you can identify the exact location of the AP you chose 

for this assignment. (Hint: your AP may or may not locate at the ground floor.) 

 

Answer the following questions:  

a) Can you find the exact location of the AP? How can you verify it? 

b) How far is the AP’s transmission range? (Indoor and Outdoor) 
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Submission Instructions 
1. Both hard-copy (printed report) & soft-copy (.pdf or .doc) of the report need to be 

submitted. Send a soft-copy to both TAs (smoon@cise.ufl.edu & yyun@cise.ufl.edu). 

Printed reports can be submitted either in class or at CSE 401(slide under the door if no 

one is present).  

2. Reports should be as clear, specific and succinct as possible. All the processed .ns1 

files and kml files used in the experiment have to be zipped and submitted via e-mail to 

the TA along with reports. All submission should be made by the deadline (Nov. 18); 

otherwise, penalty will be applied for late submission. 

3. Each group should submit only one report. In the last page, list contributions of each 

member clearly and in detail. Identify who the leader of the team is.  

 

For questions, please contact Sungwook (smoon@cise.ufl.edu) 
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APPENDIX 

 

I-A: Common questions and mistakes 

 
1) PDA: Don’t run multiple Wififofum programs. When you tap Wififofum icon multiple 

times, multiple Wififofum will run even though it does not look so as PDA is slow. Many 

groups failed to achieve correct readings by committing this mistake. To check how 

many Wififofums are running, follow the instruction below. 

2) PDA: How to check which programs are running: go to setting -> system -> memory. 

You will find some programs are running. By tapping on stop, you will terminate the 

program, or tapping on activate, the program will re-appear. If everything becomes so 

slow, you can always restart the whole thing by pushing in a pin-hole on the device. 

3) Keep an eye on GPS readings: By moving the scroll bar to the right, you will see 

latitude and longitude. Whenever moving your position to a certain extent, check if GPS 

is showing difference. 

4) The GPS does its best job where you can clearly see the sky (where you can get the 

best fix from many satellites). If the GPS device is under a tree or any other subject 

(including people), you can disturb correct GPS reading. [it may make several minutes to 

a get a fix and you would know when that happens when non-zero longitude/latitude 

readings start appearing in the corresponding Wififofum columns.] 

5) Please read the questions in the manual first before asking questions. Some ask what 

*_ap.kml or *_sp.kml means. They are the questions for which you need to seek answers 

(please read this manual carefully) 

 

I-B: Trouble shooting guide 

 

1. iPAQ: 

 

1) Make sure Wifi is ON. 

2) Bluetooth should be OFF. 

3) You have to be able to see more than 3-4 GPS fixes on the bottom of the wififofum 

software. 

4) Without available GPS coordinates, Wififofum does not save correctly. 

5) GPS should set to use COM7 in the option menu. 

6) Select the device on the menu if no AP data is displayed and power the device ‘on’ if 

still not showing any. 

7) If nothing seems to work fine, please restart the iPAQ (bottom for outside keypad one, 

top for the HP travel companion) 

8) You should save the file in a format of .wis but the file you need will be located in the 

root directory with the name like "-231245.txt". 

9) You need to transfer that file(e.g. -231245.txt) to your computer before returning the 

device. 
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2. Bluetooth GPS: 

 

1) Make sure bluetooth GPS is on (green light). 

2) After connection, bluetooth GPS has a bluelight. 

3) Upon receiving GPS coordinates, bluetooth GPS will show a white light. 

4) Connection from a laptop to the bluetooth GPS should be performed with custom 

settings to connect through COM6 (in most cases). 

5) Netstumbler running on the laptop should have the same COM port set up with the 

bluetooth setting. 

6) This one does not require to use Wififofum, only Netstumbler on the laptop. 

 

 

II-A: Windows VISTA users 
 

You can download and use Vistumbler instead of Netstumbler from the following 

website: 

 

http://vistumbler.sourceforge.net/ 

 

** Vistumbler does not show the signal strength in dbm, it shows with percentage. Please 

export to .ns1 file from Vistumbler, then read the file from Netstumbler. You will be able 

to see them in dbm. 

** Vistumbler is not a virus although some virus vaccine program may detect as a virus. 

** Vista users need to install NETCommOCX before checking out Bluetooth GPS. 

 

II-B. Additional instruction 

 

1. Signal strength (dbm) 

 

As some buildings have very good WLAN coverage, the building floor could be filled 

with all green. Please feel free to change the coverage rule in a reasonable range. E.g., 

instead of current x>-78 = green, you can either change to x>-70 = green or add blue for 

x>=68. Also, keep in mind that signal strength measurement is not only limited to the 

buildings on campus. 

 

2. Extra credit 

 

Creative or detailed additional experiments with deep analysis beyond the requirement 

may add up to extra credits depending on the quality. 

 

3. Using different programs 

 

For indoor measurement only, you may use other programs after confirming with the TA. 

In that case, you need to indicate in the report and should still submit measurement files 

(same for Netstumbler or Vistumbler users as well, as per the report submission 

instruction in this manual). 
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4. Remote (EDGE) students 

 

Please let the TA (Sungwook Moon smoon@cise.ufl.edu) know which option you will 

take. Option 1 on pg 1 of this manual is strongly encouraged and recommended. 

 

5. E-mail 

 

Put course number (e.g. CNT5106) on the title and indicate who you are when you send 

an e-mail; otherwise, your e-mail might not be read. You should contact TA via e-mail 

only at smoon@cise.ufl.edu; no phone calls.  

 

6. Additional measurements and analysis are always preferred: Please you do not just 

limit your experiment to the questions provided in the manual. You can always add more 

details to that, which will account toward extra credit (that could change your Letter 

grade). 

 

7. Please Google first for software related questions and discuss with your team members 

before you ask. Many of the questions you ask are what you can find by Googling within 

2 minutes or solved by trying on another team members’ computer. E-mails regarding 

such questions or non-experiment related questions may not be replied. 

 

8. Please check the experiment information page constantly for any changes or update. 

This is your responsibility. 

 


